Author Topic: 2008 GT225 Stern Drive Trim Not Working  (Read 132 times)

supercar

  • Newbie
  • *
  • Posts: 4
    • View Profile
    • Email
2008 GT225 Stern Drive Trim Not Working
« on: July 09, 2018, 09:54:45 AM »
The trim for the stern drive on my 2008 GT225 suddenly stopped working this week.  It was working fine on the 4th, but then when I went to use it, later in the week, the trim was not working.   

I tried to find the problem.  I can hear the relays clicking for both directions and there is one relay for each direction, so I don't think both relays would fail together and since they are clicking, obviously the switch is working.  So, my guess is the power connection is bad somewhere.  I didn't find where the hydraulic pump was located to be able to check the connection on the motor.  So, I also don't know which wire is the power wire.  I tried hunting online for a service manual, but couldn't find anything - a wiring diagram would be great.

Can anybody tell me where the hydraulic pump and electric motor are located?  Does anybody know where I might quickly find a service manual or wiring diagram?

Regards,
Dave
2008 GT225
5.0 GXi DP-S
Tower and speakers

supercar

  • Newbie
  • *
  • Posts: 4
    • View Profile
    • Email
Re: 2008 GT225 Stern Drive Trim Not Working
« Reply #1 on: July 11, 2018, 12:17:51 PM »
Could the motor and pump actually be in the top of the stern drive housing, outside of the hull?  I hunted again and I cannot find it in the engine compartment.  The boat has power steering and I see the hydraulic pump for that.

Regards,
Dave
2008 GT225
5.0 GXi DP-S
Tower and speakers

Merlin16

  • Newbie
  • *
  • Posts: 25
    • View Profile
    • Email
Re: 2008 GT225 Stern Drive Trim Not Working
« Reply #2 on: July 11, 2018, 02:24:33 PM »
I have never seen a pump and reservoir located other than beside the engine. Not on the engine. Could be either side in the far back corner against the transom.
2016 GTS 185
4.5L MPI 200hp
Phantom Grey w/Sunburst Orange